Vida

Instalación de RVM en Linux

Instalación de RVM en Linux

01 de 06

Introducción

Configurar su entorno Linux para RVM es la parte más difícil de instalar RVM. Si no está familiarizado con el proceso de compilación de Ruby desde la fuente, puede perderse un poco. Afortunadamente, las distribuciones como Ubuntu hacen las cosas bastante fáciles.

Estas instrucciones están escritas en Ubuntu. En su mayor parte, se aplicarán a cualquier distribución basada en Debian o Ubuntu. Para otras distribuciones, los nombres de los paquetes pueden diferir, pero deben instalarse las mismas bibliotecas y similares.

02 de 06

Instale GCC y otras herramientas

En primer lugar, necesita el compilador de C y la utilidad Make. Estos generalmente se agrupan con algunas otras herramientas y magia detrás de escena en un paquete llamado esencial para construir. Este es el primer paquete que debe instalarse.

$ sudo apt-get install build-essential

Además, RVM también necesitará curl para descargar archivos. Este es también un simple apt-get.

$ sudo apt-get install curl
03 de 06

Instalar bibliotecas de desarrollo

A continuación, necesitará algunas bibliotecas y sus contrapartes de paquetes de desarrollo. Dos de estas bibliotecas son readline, que le permite editar líneas de texto en bash o IRB, y zlib, que Rubygems necesitará para funcionar. También se incluye OpenSSL y LibXML.

$ sudo apt-get install zlib1g-dev libreadline-dev libssl-dev libxml2-dev
04 de 06

Instalar RVM

Ahora que ya está todo configurado, instale RVM. Esto se realiza a través de un script de shell que puede descargar y ejecutar directamente con un solo comando.

$ bash -s estable

Agregue la siguiente línea a su ~ / .bashrc archivo.

-s "$ HOME / .rvm / scripts / rvm" &&. "$ HOME / .rvm / scripts / rvm" # Esto carga RVM

Y luego vuelva a cargar su entorno bash (o cierre la ventana del terminal y abra uno nuevo).

$ source ~ / .bashrc05 de 06

Más acerca de los requisitos

En versiones posteriores de RVM, un requisitos de rvm Se agregó el comando para brindarle más información sobre los requisitos de compilación y ejecución para varios rubíes. Puede ver y examinar esta lista de requisitos ejecutando requisitos de rvm.

Requisitos de $ rvm

Incluso te da a mano apt-get comandos que simplemente puede copiar y pegar.

06 de 06

Instalar un rubí

Probablemente querrás instalar el intérprete de Ruby MRI (el intérprete oficial de Ruby, con el que probablemente ya estés familiarizado). Para hacer eso (después de instalar las dependencias de compilación, consulte los pasos anteriores), es un simple rvm install 1.9.3. Esto le dará la versión 1.9.3 del intérprete de MRI (la versión estable en el momento en que se escribió este artículo) en el último nivel de parche.

$ rvm install 1.9.3

Y eso es. Recuerda uso de rvm 1.9.3 antes de comenzar a usar Ruby y listo, Ruby está instalado.